Issue with LogiCommerce Backoffice Application

Incident Report for LogiCommerce

Resolved

Operational status confirmed; no further disruptions or issues have been observed.
Posted Jun 06, 2025 - 08:07 UTC

Investigating

We are looking into major disruptions in service access for LogiCommerce Backoffice Application and will share further information soon.
Posted Jun 06, 2025 - 08:05 UTC